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Introduction   

Formation’s earthworks planning tools allows users to quickly and interactively: 

- Construct and quantitatively compare geo-technically conforming road 

alignments. 

- Determine cut/fill and stripped volume quantities. 

- Plan surface water management through: 

 Estimating the amount and the direction of water flow. 

 Laying out and designing ditching and storage areas. 

- Construct properly sized and located stockpiles. 

- Plotting all the information on illustrative and information 3D Maps 

 

This paper will feature these tools while working through a theoretical example with 

set geo-technical criteria in an area of interest where imagery and survey data have 

already been acquired.  

This tutorial is prepared using v2024 of Muk3D|Formation.  While some of the 

commands may be slightly different to v2023 releases, the tools to complete most of 

this tutorial currently exist in v2023.   
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Road project’s geotechnical specifications 

For the purposes of displaying the earthwork planning tools within Formation, this 

paper will run through the process of planning, the earthworks portion, for a road that 

conforms to the specifications outlined below in Figures 1 to 3. 

 

We can see in figure 1 below, the cross-section of the road design. On top, we see the 

cross-section in situations where we would be placing fill above the topography to 

build the design. Below, we see the cross-section where we would be excavating 

material to build the design.  

 

From figure 1, we can see that 

the running surface will be 30 

meters wide with no grade. 

However, when placing material 

or in a ‘fill’ situation, the 

material will need to be placed 

with 6 to 1 side slopes. Also, a 

minimum thickness of 3 meters 

of fill will be required. When 

material is being excavated, or 

in a ‘cut’ situation, the 

excavation needs to be done at 

a 3 to 1 side slope. There is no 

minimum excavation depth 

however.  

 

In figure 2 below, we see a plan 

view sketch displaying the right-

of-way corridor offset 250m in 

either direction from the road 

centerline. This establishes what 

 

 

             

30m 

Min. 3m 6:1 6:1 

30m 

3:1 3:1 

Figure 1: Road design in cross-section when placing above current topography 
(top) and excavating below current topography (bottom) 
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footprint is available to construct 

within.          

In Figure 3 below, we see a 

longitudinal section through the 

centerline of a road. Depending on 

the location of the alignment, the 

point-to-point slopes along the 

centerline, and therefore of the 

running surface, cannot exceed 8%, 

10.5% or 11%.          

     

             

             

             

             

            

           

 

 

 

      

 

 

 

 

 

 

Also, the design must result in the cut and fill volume being balanced. Specifically, the 

volume of material excavated needs to be within 1% of the material placed. This 

volume does not include topsoil material that cannot be used for embankment 

purposes. 

 

 

 

Plan View 

500m ROW throughout to work in 

Road CL 

Figure 2: Right-of-way corridor 

Max. slope of 8%, 10.5% and 11% 

depending on alignment  

Figure 3: Maximum slope along centerline 
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Construct and quantitatively compare geo-technically conforming 

road alignments. 

 

 
Figure 4: Road start and end points 

 

In Figure 4 above, we can see two yellow points. These represent the two locations the 

road must connect. In this example, we will layout three different road alignment that 

must all pass through the mountainous area in between the two points. 

 

Alignment 1 

To establish a path through the mountains, we’re going to utilize information from the 

imagery itself. We can see in Figure 5 below, an urban area and, what appear to be, a 

drainage system that we should avoid. 

 

Next, and as can be seen in Figure 6 below, we apply the preset HSV (hue saturation 

value) Atlas shading to the surface to highlight changes in elevation. This is done by 

drag and dropping the style from the DB Viewer menu on the right. 
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Figure 6: Applying HSV atlas shading 

Based on this visual analysis, Alignment 1 (white 

line) can be seen, on the right, in Figure 7.  

 

    

 

 

Urban area 

Drainage system 
Figure 5: Noticeable features on the Satellite imagery 

Figure 7: Road alignment 1 
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Activate all the tools within Formation by Showing all Commands. Hit the hotkey 

located on the right-hand side of the top ribbon: 

 

*Please note, this step is only necessary in the 2024 Formation release. The 

2023 iteration has all commands visible.  

 

 

Based on this centerline, we 

can establish the right-of-way 

corridor by offsetting the 

alignment 250m in both 

directions . Go to the Polyline > 

Offset. There you will be 

presented with several 

different types of offset 

options. They all would work. In 

this case, I’m using Offset by width (Figure 8) given that I’m establishing a corridor in X 

and Y where elevation is not relevant. Offset the line in both the ‘Left’ and ‘Right’ 

directions. The corridor and centerline alignment can be seen below in Figure 9. 

 

 
Figure 9: Alignment 1 centerline and 500m right-of-way corridor  

  

Figure 8: Offset by width 
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Although this area looks quite arid in the imagery, for the purposes of displaying 

Formations tools, we are going to assume there is a 30 cm deep layer of topsoil that 

needs to be stripped before competent embankment material can be placed or 

accessed for excavation purposes.  

To account for this while creating the road surface and subsequent design lines, we will 

drop the topography, within the ROW corridor, by 30cm. After the road has been 

designed, we can establish exactly what areas will be within the design footprint and 

would have to have topsoil removed. The process can be summarized as follows: 

1. Conservatively lower topography in the construction area to account for 

construction footprint which would be stripped.  

2. Design road surface against ‘stripped’ topography and establish construction 

footprint. 

3. Re-load original topography. Use established construction footprint from 2. to: 

a.  lower surface within footprint 

b.  Estimate topsoil volume that will need to be managed. 

 

Create a polygon that corresponds to the ROW corridor. This can be done by utilizing 

the offset polylines in Figure 9. Go to Polyline > Edit > Join polylines. Select both 

polylines and they should join each other on one site. Then, go to Polyline > Edit > 

close polyline and select the joined polyline ,which should then close into a polygon. 

 

Save your 500m corridor polygon and go to Grid > Modify > Modify grid elevation 

with boundary (Figure 10). Select your grid, then your boundary and save the modified 

Grid under a new name. 

 

 

 

 

 

 

 

 

 

 

 

 Figure 10: Modify grid elevation function 
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Load your road alignment or centerline file. At this stage, we want to account for the 

minimum 3 meters of fill requirement outlined in Figure 1. The process will be as 

follows: 

1. Drape full alignment/centerline onto grid surface. This will densify the 

polyline with large number of points. 

2. Clean polyline and thin down number of points on polyline to make it more 

manageable to modify. 

3. Drape points on polyline onto grid again but this time with 3m positive offset. 

This will now create a centerline that is above the grid surface by 3m 

throughout. 

 

Begin by selecting Polyline > Drape > Drape polyline on surface (Figure 11). Drape the 

centerline onto your grid. At this point, we’ll choose a ‘Vertical offset (m)’ of 0m. 

Let’s then establish how many points now make up our centerline after draping it onto 

the surface. Go to Info > Polyline > Polyline details (Figure 12). Then select your 

polyline. Alternatively, basic layer information also appears in the Properties window 

when the layer is selected. As can be seen in Figure 12, the polyline details will display 

the: 

- Number of lines 

- Number of points 

- Attribute bounds  

- Line Distance. 

Figure 11: Draping Alignment 
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Our centerline at this stage is ~6.87km long with 1083 points. We want to reduce the 

number of points to a more manageable number.  The number of points needed will 

depend on the level of detail and granularity you would like. To do this go to Polyline > 

Clean > Remove duplicate points (Figure 13). You will then be asked for your ‘Filter 

Figure 12: Polyline Details 

Figure 13: Removing duplicate points 
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distance’. 

 

In this case, we would like a node or point on the centerline every 250m, which we 

enter as the ‘Filter distance (m)’. The output window will let you know how many 

points were removed (Figure 15)  

 

When we now check the information on the polyline  (Info > Polyline > Polyline 

details), we can now see it contains 33 points (Figure 15). 

 

 
Figure 15: Results of polyline ‘cleaning’ 

 

We will now drape the centerline onto the grid but with a 3m positive vertical offset. 

This time however, we will use the Polyline > Drape > Drape points on surface (Figure 

16) vs. Polyline > Drape > Drape polyline on surface function. The difference being, 

‘Drape points on surface’ will not densify the number of points on the line as a by-

product of draping whereas ‘Drape polyline on surface’ will. 

 

You will now have a centerline 

that is 3m above topography, at 

the very least, at those 33 

locations where there is a point 

along the centerline. 
Figure 16: Draping polyline points on surface with positive offset 

 

Now we will construct and merge the initial road surface into the topographic grid. 

Go to Structures > Roads > Create road from centerline (Figure 17). Given the 

specification laid out in Figure 1, we set: 

• Road width at 30m 

• Cut slope at 3:1 

• Fill slope at 6:1 
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• Cut & Fill shell height to 25m (this is the height of the fill and cut shell surfaces 

created to build the design. Pick a surface height you know will intersect the 

topo Grid.  

• Select option to ‘Merge into Grid’ 

Then select your grid and 

centerline.  

Formation will then create several 

new objects (Figure 18) under 

your chosen road name label. 

These objects will be:  

- cut_shell: full cut surface, along chosen 

centerline, as per specs entered in ‘Create 

road from centerline’ input window in 

Figure 17. 

- fill_shell: full fill surface, along chosen 

centerline, as per specs entered in ‘Create 

road from centerline’ input window in 

Figure 17. 

- grid:  New road surface merged into input 

grid surface. 

Figure 17: Create Road from centerline function 

Figure 18: Objects created from creating road 
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- cut_footprint: polygons of where the cut shell intersect the input grid surface. 

- fill_footprint: polygons of where fill shell intersects the input grid surface.  

 

When you select, in this case, ‘Alignment 1 – Road’ in 

the Scene Manager, the Properties window will list the 

inputs entered into the ‘Create road from centerline’ 

function and the output cut/fill volumes (Figure 19).  

The output objects created in Figure 18 and the 

resultant cut/fill volumes are all dynamic. In other 

words, they will update automatically as the input 

centerline or design inputs are modified.  

The design generates cut volume despite draping the 

alignment with a 3m positive offset. The 30m running 

surface, 250m point density and variable topography 

do create cut volume. This can be mitigated by adding 

points (Figure 24) or incorporating the elevation of the 

road shoulders into the design.   

 

In this case, we want to adjust the elevation of the 

road (road centerline), such that the cut and fill volumes are within 1% while 

maintaining a low overall volumes.  Also, as per Figure 3, we need to be mindful that 

the point-to-point slopes along the 

centerline, and therefore of the 

running surface, cannot exceed 8%, 

for this alignment. 

 

Go to Plotting > Edit line profile. 

Select your centerline and your 

stripped grid. The Long section 

editor window will appear (Figure 

20). This window will display the 

elevations of the road centerline vs. 

the topographic base surface, along 

the centerline. The point-to-point elevations and slopes of the centerline can be 

interactively adjusted (Figure 21). It can be done manually, by moving them up and 

Figure 19: Create road from centerline dynamic 
design values 

Figure 20: Edit Line profile 
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down with your cursor. In the view menu, you can set threshold values that’ll change 

the label colour if they are steeper than the entered limit. Additionally, a number of 

tools exist within the Long section editor to streamline the adjustment process. For any 

point, right-click and the option menu in Figure 22 is available. 

 Select multiple points and the menu in Figure 23 is 

available. These tools allow you to specifically set 

elevations or point-to-point slopes for multiple sections 

along the centerline.  

Right-click on the line itself 

and a new point can be 

inserted (Figure 24). 

 

 

  

 

 

 

 

Figure 22: Long section editor – single 
point options 

                   
              
               
      

                   
                 
      

Figure 21: Adjustable point elevations and slopes 

Figure 23: Long section editor – multiple point options 
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Figure 24: Road centerline & original topo with 250m point spacing (top) vs. adjusted road centerline with additional points & 
original topo (bottom)  

- Save and update the grid surface and road design after adjustments press the        

button. Based on your new design, it will update the output volumes in Figure 

19.  

- Undo any modifications that were made prior to saving, hit the        button. 
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- Update the editor to only show the post-saved surface, hit the         button 

 

- Adjust the vertical exaggeration within the editor, press the       button. 

 

In this case, the adjusted centerline configuration is such that the point-to-point 

sloping doesn’t exceed 8%, the cut/fill volumes are balanced, and the overall 

earthwork volumes have been held to a minimum. In Figure 25 below, the initial road 

merged grid configuration (centerline draped 3m above topo) is shown as the dashed 

grey line and the new adjusted configuration is the green line. 

 

 

The modified alignment or centerline results in a 

road design with the properties shown in Figure 25: 

- cut volume = 2,626,208 m3  

- fill volume = 2,635,979 m3 

  within 0.37%. 

 

Initially, the volumetrics were (figure 19): 

- cut volume = 299,076 m3  

- fill volume = 1,318,745 m3 

 

In Figure 26 below we see: 

- The Project explorer with the fill and cut footprint objects highlighted in red and 

blue respectively. 

Figure 25: Adjusted centerline alignment and outputs 
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- The Alignment 1 right of way corridor (white), fill footprint (red) and cut 

footprint (blue) overlayed over the satellite imagery/grid.  

Figure 26: Alignment 1 - Cut and Fil footprints vs. ROW 

 

Comparing the footprints to the ROW, we can 

establish that the road structure itself can be 

fully constructed within the 500m corridor. 

Beyond that, we can estimate the volume of 

topsoil that will be generated and will need to be managed with this alignment. 

Go to Info > Polyline > Polyline area and select both polygons separately to establish 

their area (Figure 27).  

 
Figure 27: Fill and cut footprint areas 

We are working with the assumption that there is 30cm of topsoil that will have to be 

stripped within the road footprint. As a result, for this alignment: 

- Topsoil volume = (718,787 m2 + 173,265 m2) * 0.3 m/m2 = 267,615 m3 
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Alignment 2 

 

Let’s establish and evaluate a second alignment utilizing the same process as above for 

alignment 1.  

1. Utilize features in satellite imagery and topography to establish alignment. 

2. Create right-of-way corridor polygon offset 250m on either side from alignment. 

3. Drop topographic surface by 0.3m within ROW to account for stripping. 

4. Drape entire polyline on topographic surface with ROW stripped. 

5. Clean polyline to reduce the number of points to a manageable level. 

6. Utilize Polyline > drape > Drape points on surface with 3m positive offset  

7. Build road surface from centerline as per specifications. 

8. Utilize Long section editor to balance cut/fill volumes while adhering to geo-

technical criteria. 

However, in this case, we will cross the mountains towards the east and relax the 

point-to-point slope restriction to 10.5%. Alignment 2 can be seen below in Figure 28. 

 

 
Figure 28: Alignment 2 

 

The alignment 2 outputs, prior to volume balancing and setting the 10.5% point-to-

point slope restriction can be seen below in Figure 29. The outputs following 
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adjustments, as well as the updated alignment can be seen in figures 30 and 31 

respectively. 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Figure 29: Alignment 2- preliminary outputs 

 

 
Figure 31: Alignment 2 - adjusted long section profile 

Figure 30: Alignment 2 - adjusted outputs 
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- The Alignment 2 right of way corridor (yellow), fill footprint (red) and cut 

footprint (blue) overlayed over the satellite imagery/grid can be seen in Figure 

32 below. 

 

 
                 Figure 32: Alignment 2 - Cut and Fil footprints vs. ROW 

 

For this alignment: 

- Topsoil volume = (1,039,941 m2 + 276,288 m2) * 0.3 m/m2 = 394,869 m3 

 

Alignment 3 

Let’s establish and evaluate a third alignment, that will cross the mountains in the west 

and has a max. slope spec of 11%. Alignment 3 can be seen in Figure 33 below. The 

alignment 3 outputs, prior to volume balancing and setting the 11% point-to-point 

slope restriction can be seen below in Figure 34. The outputs following adjustments, as 

well as the updated alignment can be seen in figures 35 and 36 respectively. 
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Figure 33: Alignment 3 

 

  
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
         
       

 

Figure 34:  Alignment 3 – Preliminary 
outputs 

Figure 35: Alignment 3 – Adjusted outputs 
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Figure 36: Alignment 3 – Adjusted long section profile 

- The Alignment 3 right of way corridor (orange), fill footprint (red) and cut 

footprint (blue) overlayed over the satellite imagery/grid can be seen in Figure 

37 below. 

 Figure 37: Alignment 3 - Cut and Fil footprints vs. ROW 

For this alignment: 

- Topsoil volume = (604,373 m2 + 178,405 m2) * 0.3 m/m2 = 234,833 m3 
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Comparing alignments 

 

The process above allows us to quantify and compare the alignments against each 

other. Table 1, below, lists the road lengths, total cut+fill volumes, estimated required 

stripping volume and slope restriction. 

 
Table 1: Summary table of alignments 

 
 

Surface water management 

Let’s proceed with Alignment 1 and utilize that road configuration to plan around. We 

will utilize the merged grid surface, with the Alignment 1 road structure built-in, as our 

base topography. 

 

Watershed tools 

To begin, we need to hydro-reinforce our topographic surface to model the flow of 

water properly. This is done, within Formation, in the following steps: 

1. Define the location of any ponds/dams/sinks that allow water to collect. 

2. Fill depressions in the grid. If a point can’t flow anywhere and its not regarded as 

a sink, then the point elevation is modified until all points can flow somewhere 

(except sinks) unless they are on the edge of the grid. 

3. Determine flow direction from each point. 

4. Count the number of predecessor points that contribute to flow through each 

point. 

5. Create streams for points that have more than a threshold area that contributes 

to flow. 

 

To generate this surface from the topography you’re working with, go to Water >  

Watershed > Create a Watershed (Figure 38). Please note, processing time will depend 

on the size of input grid. We advise you utilize the Grid > Create > Extract from existing 

grid to delimit the topography to the needed area. 

Length (km) Cut + Fill volume (m3) Topsoil volume (m3) Slope restriction (%)

Alignment 1 6.6 5,262,187                               267,615 8.0
Alignment 2 8.4 6,151,256                               394,869 10.5
Alignment 3 6.0 4,421,284 234,833 11.0
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The software will ask you to identify any existing basins or ponds that it should 

consider in its processing.   

 
Figure 38: Creating a Watershed 

After processing is complete, Formation will create the files that can be seen in Figure 

39 below. Please note, the flow_grid created from the topography is no longer suitable 

for doing geometric modelling.  The Fill 

depressions part of the algorithm may 

modify surface elevations by an 

unspecified amount.  

 

After processing is complete, Formation 

will also generate the output seen in Figure 

40 below. 

The default in this case, generates streams 

where the minimum catchment area is  

47,626,669 m2, 10% of the total grid area.  

 
 

Figure 40: Outputs generated from watershed processing 

Figure 39: Files generated from creating watershed 
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In order to re-generate streams with more granularity, go to Water >  Watershed > 

Regenerate stream network and set a lower minimum catchment area (figure 41). 

 In this case, we’re going to set the minimum catchment area to 2,000,000 m2 and re-

generate the stream network. Figure 42 below displays the difference in streams 

generated between a minimum catchment area of 470,626,669 m2 (left) and 

2,000,000m2 (right). 

                

Sump design  

In Figure 43 below, we can see the streams in blue, the 500m ROW corridor in white 

and the road footprint in black overlaid over the topography with HSV shading, on the 

Figure 41: Regenerating stream network 

Figure 42: Streams generated with 470,626,669 m2 min. catchment area (left) vs. 2,000,000 m2 min. catchment area (right) 
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left, and satellite imagery on the right. The yellow squares highlight areas where a 

stream crosses into the ROW corridor where surface water may become an issue. 

  

 

• Area 1: 

o Although the streams cross into the ROW corridor, it does not contact the 

road footprint. More importantly, we can see from the HSV shading that 

the topography is grading down, to the north, and away from the road. It 

this case, surface water will flow adjacent to the road but away from it. 

• Area 2: 

o The water crosses into the corridor and seemingly contacts the road 

footprint, however, we can see in the satellite imagery that the stream 

crosses an existing ditch that, we’ll assume, should intercept, and divert 

the surface water in this case. 

• Area 3: 

o The water stream crosses into the ROW and through the road.  From the 

HSV shading, we can see the topography grades down into the road from 

the north-west. Surface water, in this area, needs to be managed. We’re 

Figure 43: Streams, road footprint, ROW corridor and topography 

1 

2

 
 

1 

3

 
 

1 
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going to place and design a ditch to intercept the stream and carry the 

water to an excavated sump where the water will collect and be pumped 

out. The ditch and storage area will be designed inside the ROW and 

outside the road footprint while utilizing the existing grading of the 

topography to minimize the excavation. Figure 44 below shows a 

preliminary layout of the ditch and sump as red polylines. 

 
Figure 44: Ditch/sump layout, ROW and road footprint  overlaid over HSV topography 

To size the capacity of the sump, we need to estimate the amount of surface water 

that will flow through those streams. In lieu of a detailed hydrological analysis, we’re 

estimating peak storage volumes by determining the catchment area feeding this 

stream and multiplying it by the appropriate historical precipitation data for this 

region: 

 Needed storage capacity: Catchment area (m2) x Precipitation (m/day) = Volume 

(m3/day) 

 

In this case, we’ll assume a 24h hour rain event producing 30mm of precipitation.  To 

determine the catchment area go to Water > Watershed > Generate catchment 

(figure 45). Make sure your flow_grid and streams objects are loaded: 

1.  Formation will ask you to select a grid with flow directions, this must be your 

flow_grid.  

2. It will then ask you to select a point. Select a point exactly on the stream of 

concern (figure 45). 
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Formation will then generate a surface and 

outline for the catchment area. The 

catchment area can be seen, in green, in Figure 46 below. Formation will calculate and 

display the catchment area value in the output window (Figure 46). 

 

 

 

Selected point 

Figure 45: Generate catchment area 

Figure 46: Generated catchment surface, outline, and area  
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Needed storage capacity: 5,224,276 (m2) x 0.03 (m/day) = 156,728 (m3) 

 

We will now incorporate our water storage structure into the topographic surface with 

the road structure already merged in.  Begin by loading your merged road grid, not 

the flow_grid. 

The sump will be designed from its crest in this case. Because this is a purely excavated 

structure, the crest line also corresponds to the footprint. And given the need to 

construct this structure within the 500m corridor but outside the road footprint, 

designing from the crest here is very practical.  

The sump crest line can be seen in figures 45 and 46 above. The sump’s base elevation 

will be offset relative to the sump’s crest elevation and we want a sump with a 

consistent base elevation to maximize containment. As a result, we need to set a 

consistent elevation on the crest line. 

 

Go to Layer > Change layer elevation (Figure 47). In this case, we’ll set the crest 

elevation to 1598m, which is close but above the topography throughout the sump’s 

footprint.  Select the layer with your sump crest. Set the ‘Elevation is…’ to absolute 

and enter your desired elevation. 

 

Next, go to Structures > Excavations > 

Excavation from crest (Figure 48). Name your layer, set the excavation slope and the 

depth, relative to the crest, to 

excavate down to (Shell height). 

Check ‘Merge into grid’ to create a 

dynamic model. Then select your 

merged road grid and sump crest 

polygon. 

Figure 47: Change layer elevation 

Figure 48: Excavation from crest 
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Formation will generate the layers, listed with red font in Figure 49 below. 

The ‘grid’ layer will now have the sump 

and road structures incorporated. 

Additionally, the excavation is a dynamic 

structure. When you select the overall 

‘Sump’ layer in the Scene manager, the 

Properties window will list the variable 

Inputs and Output (Figure 50). You can 

change the excavation slope and depth in 

the inputs which will dynamically update 

the excavation volume.  

Next, we’re going to add a dynamic pond 

surface. Go to Structures > Pond > Create a 

pond surface or hit the         button (Figure 

51). Name your pond layer and pick an 

elevation above sump’s base and below the 

crest. I’m starting with an elevation of 

1585m. Then select a point within the new 

sump. The generated pond surface, within 

the excavated sump, can be seen in Figure 52 below. 

New pond layers will be generated in 

the Scene manager and the dynamic 

inputs and outputs of the pond are 

visible in the Properties window 

(Figure 53). 

 

We can see in Figure 53, in the 

properties window, the output 

volume is 34,583 m3.  

Figure 49: Layers generated from excavating from crest 

Figure 51: Create pond surface 

Figure 50: Excavation from crest dynamic properties 

Figure 62: Excavated sump, pond, 500m ROW and road footprint  
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Our needed storage capacity is 156,728 

m3. Additionally, we would like to have 

some level of freeboard. Given the sump crest’s surface area of 37,195 m2 (figure 50), 

we can estimate that 1m of freeboard in this situation will correspond to ~ 37,000 m3. 

As a result, to have capacity for 156,728 m3 of water, while maintaining 1m of 

freeboard, the actual sump capacity should be ~194,000 m3.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 53: Dynamic pond layers and dynamic properties 

Figure 54: Pond overtopping 
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As can be seen in Figure 54 above, increasing the pond elevation to 1589m causes the 

pond to overflow with a water volume of 136,639 m3, well below the needed ~194,000 

m3. In this situation, we can either dynamically expand the area of sump through the 

crest line or increase the excavation depth (shell height) of the sump. In this case, we 

will increase the excavation depth.  

To begin, find the max. or close to the max. elevation before the sump overtops. Set 

your pond elevation to that value. In this case, the pond stays contained within the 

sump up to an elevation of 1588m. 

Select the Sump layer in your Scene Manager. Increase the Shell Height then select the 

Pond layer in your Scene Manager and verify the pond volume. Increase your sump 

shell height until you’ve reached a pond volume of ~194,000 m3. In this case, the shell 

height needed was 23.5m. The final sump (left) and pond (right) properties can be seen 

in figure 55 below. Make sure to save the sump and pond files. 

 

To visualize items in section quickly, utilize the Section from 2 points (Figure 56) 

function. Begin by hitting the           button. Create your section line. In figure 57 below, 

we can see the section layout in 

plan view and the topography with 

the sump excavation and pond 

surface in section. 

 

 

Figure 55: Final sump (left) and pond (right) properties 

Figure 56: Section between 2 points 
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Ditch design  

Next, let’s add in our intercept ditch.  In 

Figure 58, on the right, we can see the 

ditch line (blue), intercepting the incoming 

streams (navy) and leading to the sump. 

All the while, inside the ROW (white) but 

outside the road footprint (red).  

We’re going to create a merged grid 

surface once again with the ditch 

incorporated as a dynamic model we can 

1 
2 

2 1 

Figure 57: Sump and pond section layout and cross-sections 

Figure 58: Ditch lay-out relative to streams, ROW, road footprint and 
sump 
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manipulate in the long profile editor. The ditch line here is the centerline of the ditch 

base. 

 

We want the ditch to achieve at least 1m of excavation depth and at least -1% slope 

along the ditch bottom. 

Go to Polyline > Drape > Drape polyline on surface. Drape the ditch line with a ‘-1m’ 

offset. This will set your ditch line 1m below the topographic surface.  

Go to Plotting > Edit line profile. Select your draped/offset ditch line and merged 

Sump Grid. In Figure 59 below, we see the merged grid (dashed black), -1m offset ditch 

line (blue) and the final modified ditch line (green). As per the min. 1m depth/1% slope 

requirement, we adjusted the ditch line such that it is either at or below the blue line 

in depth with at least a point-to-point slope of -1%.  When complete, update your 

model by pressing the       button.  

 

Go to Structures > Excavations > Create ditch form centerline (figure 60). Select the 

specification of the ditch excavation and make sure to ‘Merge into grid’.  

 

Figure 59: Edit line profile of ditch base centerline. Editing to achieve at least 1m of depth below topo and at least -1% slope. 
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Select the intercept ditch layer in the Scene Manager to view the excavation volume 

and maximum depth achieved for the excavation (Figure 61). 

 

 
                                

 

 

 

 

 

 

 

 

 

 

 

 

Stockpile/Dump Design 

Let’s continue with the Alignment 1 configuration and plan our stockpiles: 

- All stockpiles need to be placed outside the construction (cut/fill) footprints but 

within the 500m ROW.  

- When the earthworks portion of the road is constructed, topsoil will be placed 

on side-slopes and other areas of the design to protect against erosion. 

- A substantial amount of topsoil may need to be stockpiled depending on how 

much completed design surface is available to be finished with topsoil as it’s 

getting stripped.  

- Additional planning should be done to maximize direct placement of the topsoil 

to avoid rehandle. However, let’s assume we will need to stockpile all the topsoil 

stripped. 

 The alignment 1 road itself will generate an estimated 271,319 m3 of 

stripped topsoil overall (table1). 

 Additionally, the topsoil will need to be stripped from the sump and ditch 

footprints outlined in the section above. From figure 55 and 61 

respectively, that a total of: 

▪  (37,194 m2 + 10,742 m2 ) * 0.3m3/m2 =  14,380 m3 of topsoil 

Figure 60: Create ditch from centerline 

Figure 61: Intercept ditch properties 
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 The total volume of topsoil to be stockpiled is 285,699 m3 

- In order to minimize haul distances, we will assume that there will be two topsoil 

stockpiles that will be located on either end (north and south) of the alignment. 

Each stockpile will contain half of the volume or ~143,000 m3 

- Beyond that, the non-topsoil material excavated for the ditch and sump, will be 

stockpiled, and used the backfill the ditch and sump after the road has been 

completed.  

 From figures 55 and 61, we can see the total excavation volume for the 

sump and ditch are 304,348 m3 and 6,088 m3 respectively.  

 As per above, we’ve established 14,380 m3 of that is topsoil.  

 There will be 304,348 m3 + 6,088 m3 - 14,380 m3 = 296,056 m3 of 

embankment material to be stockpiled adjacent to the ditch and sump. 

Overall, we will have: 

- Topsoil stockpile 1 in the ‘South’ of ~143,000 m3 

- Topsoil stockpile 2 in the ‘North’ of ~143,000 m3 

- Embankment material stockpile in the ‘South’ of ~296,000 m3 

Let’s begin in the ‘south’.  In figure 62 below, we see the 500m corridor (white), the 

road footprint (red), the ditch footprint (blue) and the sump in the ‘south’ 

  

  

  

  

  

  

  

  

  

  

  

  

Figure 62: Alignment 1 features in the ‘south’. 
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We’ll begin by placing the Embankment material stockpile of ~296,000 m3 adjacent to 

the sump. Given our need to construct the stockpile, to a defined capacity, within an 

area between the ROW and road footprint, we will construct the stockpile from the 

footprint. 

Begin by creating a reasonably sized footprint in plan view. The elevation of the 

footprint is not a concern. The footprint simply needs to be appropriate in X and Y. 

Go to Polyline > Create > Draw a line (figure 63) and create a closed polygon. Once 

again, the elevation does not matter here but we recommend an elevation above the 

topography so that the polygon is visible over the topography. 

Then, go to Structures > Dump > Dump from footprint (Figure 63). This will create a 

dynamic dump structure within the footprint of your polygon. Select an initial crest 

elevation that is reasonable. In this case, the topography’s elevation, within the 

footprint, maxes out around 

1605m.  As a result, our initial 

Crest Elevation (m) is set at 

1615m. You can also set the 

sideslopes. Formation will then 

generate the layers that can be 

seen, in red font, in Figure 65 
Figure 64: Dump from footprint tool 

Figure 63: Initial footprint of Embankment material Stockpile (brown) 
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below. Select the Embankment Stkp layer in the Scene manager and it will display the 

items in Properties window that can be seen  in Figure 66 below. 

 

 

 

 
 

 

 

 

 

 

 

 

 

Figure 65: Dump from footprint generated files 

 

In the outputs section of Figure 66, we can see that the initial stockpile configuration is 

375,673 m3. Our target volume is 296,000 m3. To reduce the size of the stockpile by ~ 

80,000 m3, there exists two options: 

1. Reduce the crest elevation of 1,615m. 

2. Modify the input polygon seen in figure 63. 

 

For option 1, simply type a new value into the Crest elevation value in the Inputs 

section of the properties window and the volume will update dynamically. In this case, 

1,610.75m gets us to 295,807 m3. 

 

For option 2, go to Polyline > Edit > Move point on line and modify the configuration 

of the input footprint polygon. 

 

Please note that the newly created merged grid, with the stockpile incorporated, must 

be visible or the stockpile outputs won’t update. 

 

Figure 66: Embankment Stockpile properties 
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Next, we repeat the process and place the two 143,000 m3 stockpiles on either side of 

the alignment. As always, continue to build off the previously created merged grids 

towards a final grid will all components. 

 

Plotting 

Let’s combine all the imagery, designs, and topographic data into plotted imagery. 

 

We are going to modify the satellite image to display the different design features. 

Then overlay that modified imagery over the topographic surface. 

 

The outlines that we’re going to utilize are the structure footprint layers automatically 

generated by Formation throughout the design process. This will include: 

- The Alignment 1- Road cut footprint. 

- The Alignment 1- Road fill footprint. 

- The Intercept ditch footprint. 

- The Embankment stockpile footprint 

- The Topsoil north stockpile footprint 

- The Topsoil south stockpile footprint 

 

Go to Imagery > Add filled outlines to image (Figure 67).  

 
Figure 67: Add filled outlines to image 
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Hit the        button in the Base image row and load the clean.jgw file in the imagery 

folder. Then name the Output image.  

Hit the         dropdown button and choose whether you would like to fill that particular 

footprint with a color or a texture                           . 

 

The ‘colour’ option fills the outline with a standard colour of your choosing. The 

‘texture’ option allows you to fill the outline with an image. The 2024 version of 

Formation comes with four textures you can use. They can be seen in Figure 68 below. 

 

 
Figure 68: Formation textures 

These textures are also present in the DB Viewer and can be added to any layer, within 

Formation, by dragging and dropping them into the main viewer and selecting the 

layer you would like to apply it to.  

 

Let’s begin by selecting the ‘Colour’ option initially (Figure 69). Hit the        button and 

select the Alignment 1 Road’s cut footprint and make it blue. Then hit okay. Repeat this 

process with all the outlines you’d like to highlight 

with a solid color. Is this case, we’re coloring the 

Alignment 1 Road fill footprint in red and the 

Intercept ditch footprint in cyan. We’ll utilize the 

textures to fill in the stockpile footprints. Hit the 

‘Click to 

select 

image’ 

button in 

the Texture row. The texture files from figure 

68 can be found in your root project directory 

folder. In this case, the Embankment material 

stockpile footprint will be ‘tailings’ texture and 

Figure 69: Colour outlines 

Figure 70: Texture outlines 
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the topsoil stockpile footprints will be ‘dirt’ texture. The selection can be seen in Figure 

71 below. 

 

Hit Ok and two new files of your 
Output image will be created in 
your active work folder. One will be 
jpg and the other a .jgw. Drag and 
drop the .jpw file you’re your final 
merged grid surface.  

Additionally, we’ll make the pond 
surface visible to highlight the 
presence of the sump. And finally, 
make the 500m alignment ROW 
polylines visible for visual 
reference. Go to Imagery > Export. 
There you can either copy or save 
the imagery you see in the main 
viewer. The imagery can be seen in 
Figure 72 below. 

 

 

Figure 72: Modified satellite imagery overlaid over topography  

Figure 71: Add filled outlines to image selections 


